Versions of WP-CLI Prior to 0.23.0 Are Incompatible with WordPress 4.5

restful-wp-cliDaniel Bachhuber, maintainer of WP-CLI, a popular command line interface utility for managing WordPress sites, has released version 0.23.0. This release includes a number of bug fixes, improvements, and features, but the most important thing to note is that earlier versions of WP-CLI will not work with WordPress 4.5.

According to Bachhuber, WordPress 4.5 loads a file in wp-settings.php and since WP-CLI uses a custom wp-settings-cli.php file, 0.23.0 and above are the only versions compatible with WordPress 4.5. Bachhuber created a new ticket on Trac to start a discussion on using wp-settings.php instead of the custom file.

“WP-CLI uses a custom wp-settings-cli.php to load WordPress, instead of wp-settings.php,” Bachhuber said. “While I appreciate the historical justifications for the bootstrap process, it would be much better if WP-CLI could use wp-settings.php because, occasionally, there are substantial problems arising from needing to maintain a fork.”

To see a full list of changes with detailed explanations on how to use new features such as installing community commands from the package index, check out the release post.

2

2 responses to “Versions of WP-CLI Prior to 0.23.0 Are Incompatible with WordPress 4.5”

  1. More like WordPress 4.5 Requires WP-CLI v 0.23… .23 still works with older versions of WP but once upgraded to WP 4.5 older versions of wp-cli will no longer work. Title is just misleading.

    • The more I read the official post and my title and then the official post and your title, the more I realize both are confusing. So, I changed it to something completely different yet accurate.

Newsletter

Subscribe Via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

%d bloggers like this: