Plugin And Theme Devs Have Reason To Celebrate

A topic of discussion that’s popped up numerous times within the WP Hackers Mailing List as well as other places throughout the community is when WordPress would stop supporting PHP version 4 and move up to version 5. Well, the good news for all WordPress theme and plugin developers is here in that starting with WordPress 3.2 scheduled for release sometime in the first half of 2011, the minimum required PHP version will be 5.2 while MySQL will be raised to 5.0.15. Mark Jaquith explained on the WordPress development blog why the time was right to finally make the move:

The numbers are now, finally, strongly in favor of this move. Only around 11 percent of WordPress installs are running on a PHP version below 5.2. Many of them are on hosts who support PHP 5.2 — users merely need to change a setting in their hosting control panel to activate it. We believe that percentage will only go down over the rest of the year as hosting providers realize that to support the newest versions of WordPress (or Drupal, or Joomla), they’re going to have to pull the trigger.

Just for the sake of knowing, WPTavern.com is running on a shared webhosting server running PHP 5.2.4.

There are 12 comments

Comments are closed.