In the WordPress Developers channel on IRC today, Ryan Boren announced that the target date for the release of WordPress 2.8 is June 10th. There are a couple other things that were announced as well: WP 2.9 will require MySQL 4.1.2 or greater.  This is raised from the current requirement (more…)