5 Comments

  1. Marcus L Tibesar
    · Reply

    When does the WordPress PHP minimum rise to PHP 7? Seems to me that WordPress AND all Plugins should be on the same sheet of music…

    Report

    • Denis Žoljom
      · Reply

      Should be at the end of the year if I’m not mistaken. And it’s about time.

      PHP 7 is already EOL. We need to adapt and try to teach plugin and theme authors about the advantages of good coding practices.

      Report

  2. Roger
    · Reply

    The article talks about the maximum version, not the minimum one.

    Still it surprises me it wasn’t raised to 7.3!

    Report

  3. Anton
    · Reply

    Like I commented in the issue, it doesn’t matter what the maximum PHP version is, because any hard version limit is arbitrary, and any hard version limit is wrong. This point didn’t seem to have reached the intended audience, and was largely ignored. Even Rarst, when he raised the same point, was told:

    Given PHP’s poor adoption curves, all that this means is that you can’t release a plugin through WordPress.org that only works on 15% of WordPress sites.

    This is a non-answer, because the choice of platform, even a poor one, cannot come from anyone but the developers of the products themselves. Even more so, given that WP runs on PHP versions that are higher than the current arbitrarily set minimum.

    The only acceptable solution is to make this check optional, like I write here.

    This is outrageous.

    Report

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: