30 Comments


  1. You guys are sharp – looks like update time!

    BTW – do you guys still deactivate all plugins before you update and then reactivate them again?
    Or am I living in the past?

    Reply


  2. Awesome!

    Now to wait, and watch the automatic upgrade happen! (I love those filters. I haven’t manually updated a Theme or Plugin since 3.7 was released. This will be the first time to observe a core major-release auto-upgrade.)

    Reply
  3. Nate

    That image below “Responsive Admin Design” doesn’t really show off the admin backend ;)

    Reply

  4. No more WP community news in WP admin panel? :(

    It was the usual place where I would check interesting videos and WP Tavern news… I envision big drop in WP Tavern traffic…

    Also, for the WP blog there is no more option to select number of messages.

    Reply
  5. Syrehn

    The one thing that I’m missing in 3.8 is the menu separators. While I love the new design overall, I personally don’t like having everything mashed together with no separator lines between sections (it feels messy when plugins/themes start adding menu items) so I did the following to bring them back:

    In my themes functions.php I added:

    function wptutsplus_admin_styles() {
    wp_register_style( ‘wptuts_admin_stylesheet’, get_stylesheet_directory_uri() . ‘/css/admin-styles.css’ );
    wp_enqueue_style( ‘wptuts_admin_stylesheet’ );
    }
    add_action( ‘admin_enqueue_scripts’, ‘wptutsplus_admin_styles’ );

    I then created a new stylesheet called admin-styles.css with the following CSS (placed it in a CSS folder in my child theme):

    #adminmenu li.wp-menu-separator {
    background-color: rgba(255,255,255,0.15);
    height: 1px;
    margin: 0;
    }

    Reply

  6. I agree with Tomas M.
    I did like the WP community news. It’s how I read new posts from this blog.

    Reply

  7. I’m disappointed in this update. I started to write a post this morning only to discover all the editing widgets had disappeared in visual mode. If you hover over the places where they used to be you can still use them, but the pictures are gone. Nothing I do brings them back. Suggestions are appreciated.

    Reply

  8. @Michael Scott – sounds like a browser caching issue to me – browsers can hold onto scripts/stylesheets (such as those used for TinyMCE) tenaciously. Try clearing the cache or a different browser?

    Reply

  9. @Chip Bennett -Apparently the new update doesn’t like Chrome. I cleared the caches, cookies, history and etc., and it didn’t fix the problem. When I use Firefox and Safari the edit widgets are present. So, it looks like I’ll have to use a different browser until someone fixes the problem the Chrome compatibility update. Thanks for your speedy response.

    Reply
  10. Lio Eters

    @Syrehn – I did pretty much exactly that, immediately upon updating. I think menu separators help see the sections better.

    Also, the new responsive dashboard widget columns are not working well for me. I’m still trying to fix it so it displays as before – I’m working on a wide-screen, and it won’t let me have 2 columns..

    Reply
  11. shanna

    Well it looks like the roll WordPress has been on finally came to a grinding halt. 3.8 has created some serious usability issues. It looks like mid-life crisis time has finally arrived for WP creators.

    Why would anyone in their right mind abandon backward compatibility on the usability front? 3.7 was the pinnacle of perfection for easy-on-the-eye reading that made it super easy to quickly pick out what you wanted. This was due not only to careful use of the right contrast but also to various techniques for separating different components on the page. Now that is all out the window.

    In 3.8 fonts may be larger but they are harder to read due to contrast issues. And individual things on a page a harder to find quickly. The whole things reduces productivity big time and is going to create difficulties for people with sensitive eyes and imperfect vision. That is one of the foundation stones of usability, so what is going on here?

    I was stunned to upgrade to 3.8 and without any warning be forced into this admin downgrade. Every usability specialist ought to know that white text on a black background is a huge usability issue. Yet that is the default sidebar color scheme! The very first thing i did when i saw that was look for an option to use the old ‘classic’ style, but alas no one seems to have thought it was important to preserve continuity in this area. This exemplifies the same attitude that makes opponents of smart meters so livid. You took away my nice usable admin without notice and without giving me a choice!

    As a WordPress developer the WordPress team and future has just been downgrading in my mind by several basis points. WordPress is over the hill now.

    Reply


  12. All my sites and all client sites now updated to 3.8.
    I like the new modern look, but I had no problems with the old version.

    I did notice that the automatic update process was pretty quick and as it turns out… pretty reliable.

    Reply

  13. I like it it, but can’t seem to get it set up. I am on Chrome, and I don’t know if that is the problem. If so, what do you recommend I change to.
    Is there a How to Set Up 2014 for Dummies? I really am one.

    Reply

  14. The latest update is a disaster if you’re using Chrome. As a website publisher I had to scramble to get my articles up so I started using Safari, and in a curious way I’m glad I did. I never knew what I was missing. I did try FireFox but it’s become so clunky overall I elected not to use it. So, to sum up, in my opinion, and experience, Chrome and WP are no longer getting along.

    Reply
  15. Syrehn

    @Lio Eters
    The guys at “Digging Into WordPress” put up a post about bringing back columns. Maybe this will help you:

    http://digwp.com/2013/12/bring-back-single-column-dashboard-in-wp-3-8/

    @Michael Scott
    I use Chrome as my primary browser of choice for surfing/blog posting etc. (FireFox for dev tools like firebug) and I haven’t run into any issues yet running v3.8 and Chrome Version 32.0.1700.41 m Aura.

    I tested all post/page new/edit features as well as “distraction free” writing and can’t find any hiccups. I know that on rare occasions a router can hold/cache a website until it’s cleared/flushed (it’s happened to me before). Maybe that could be an issue?

    @Jobi Harris
    What exactly are you trying to set up in 3.8?

    Reply

  16. I publish a website and I have to use the New Post/Edit page, and when in visual mode in Chrome, all of the editing pictures are gone, such as quote, link, copy and paste, undo, and etc. If you hover over where they used to be they are there, but the pictures in Chrome no longer exist since the upgrade to 3.8. I cleared my browser cache, and etc., but nothing works. Everything works as it should in Safari and Firefox.

    Update: I just went back into Chrome, reloaded the page, which I had done before to no avail, and now the New Post/Edit page is working as it should. WTF?

    Reply
  17. Nicole Dreyer-Holgate

    I’m suddenly having caching problems on a site that I am developing after updating to WP 3.8.

    Don’t want to blame the update yet…anyone have any idea whether there is some new thing that 3.8 has built in – cache wise?

    Reply
  18. Nicole Dreyer-Holgate

    @ieio Thanks for that! I thought I was slowly going mad. I have checked everything. Plugins. Hosting provider. The only other change was the update :/

    Am hoping there are some solutions online today. Please let me know if you hear of anything and I will do the same?

    Reply

  19. After giving “Parker” a little time I have to somewhat agree with shanna above.

    The admin pages are actually harder to read and a strain on the eye with regular use.

    As a little experiment to myself I have 3.7 and 3.8 both open and certainly the old one (designed by Elliot Jay Stocks I believe) is a much easier read.

    Not a good sign when plugins are appearing to make the default dashboard different!

    I hope 3.7.1 sorts these issues.

    In fact, it’s probably about time I contributed :o)

    Reply

  20. When and how will 3.8 work on Chrome again, for crying out loud???

    Reply

    1. @Juergen I’m using it on Chrome – what problems are you having?
      I’ve not noticed any problems.

      Reply

    2. I finally ended up clearing all of the caches in Chrome, and then rebooting my iMac, which still didn’t do the trick, and then, out of frustration I kept reloading the affected pages, and finally everything worked. I have my editor back. Weird.

      Reply

Leave a Reply